Desarrollo web PHP

Error al actualizar a Symfony 2.1.11 – kriswallsmith/assetic

Cuando realice la actualización utilizando:

composer update

Se presento un error en el bundle:

kriswallsmith/assetic

En pantalla se podia mirar el siguiente error:

PHP Fatal error: Declaration of Symfony\Bundle\AsseticBundle\Factory\Worker\UseControllerWorker::process() must be compatible with Assetic\Factory\Worker\WorkerInterface::process(Assetic\Asset\AssetInterface $asset, Assetic\Factory\AssetFactory $factory)

Para corregir este problema basta con corregir en el composer y colocar esta linea:

"require": {
...
"kriswallsmith/assetic": "1.1.0",
...
}

 

Y forzamos a utilizar una versión anterior de assetic.

De esta manera se soluciona.

 

Fuente:

https://github.com/symfony/AsseticBundle/pull/200

 

 

 

Similar Posts

Leave a Reply

Your email address will not be published. Required fields are marked *

%d bloggers like this: