Archive for Ubuntu

Julio 16th 2012

Bugtraq, distribución de Linux para Pentest y Forense

Número de lecturas: 6538
{lang: 'es-419'}

Bugtraq (@BugtraqTeam) es una distribución basada en el kernel 2.6.38 y ofrece una amplia gama de herramientas para realizar pentest y análisis forense. Esta distribución se puede instalar o bien utilizar como un LiveCD desde un DVD o USB.

Entre otras muchas herramientas, Bugtraq ofrece herramientas para:

  • Scripts de instalación automatizados par herramientas como Nessus, OpenVAS, Greenbone, Nod32, Hashcat, Avira, BitDefender, ClamAV, Avast, AVG, etc…
  • Malware
  • Herramientas de protección
  • Auditoria web
  • Fuerza bruta
  • Análisis forense
  • Sniffers
  • Virtualización
  • Anonymity and Tracking
  • Detección de vulnerabilidades
Bugtraq se puede descargar en inglés y en español y… antes que pregunten el user y password son “bugtraq” y “123456” respectivamente

Fuente:

http://blog.segu-info.com.ar

Mayo 14th 2012

Como instalar Apache+PostgreSQL+PHP en Ubuntu

Número de lecturas: 73402
{lang: 'es-419'}

La instalacion se hara desde la consola ya que muchas veces es el unico medio diponible en servidores o cuando se hacen instalaciones mediante el uso de SSH.

También hay formas mas sencillas de hacerlo mediante el uso de las herramientas gráficas como pueden ser  Synaptic, KPackageKit y muchas otras utilidades.

Como dijimos estos comandos son para Ubuntu así que usaremos sudo para ganar privilegios y la utilidad apt-get.

El proceso es bastante sencillo y rápido.

Primero instalamos Apache con el comando

sudo apt-get install apache2

Luego PHP con el comando

sudo apt-get install php5

Luego PostgreSQL  con el comando

sudo apt-get install postgresql-8.4

Finalmente conectamosPostgreSQLcon Apache y PHP  con los comandos

sudo apt-get install php5-pgsql
sudo apt-get install libapache2-mod-auth-pgsql

Para asegurarnos reiniciamos PostgreSQLy Apache con los comandos

sudo /etc/init.d/apache2 restart
sudo /etc/init.d/postgresql-8.4 restart

Si les indica que el comando no funciona prueben de esta forma:

sudo /etc/init.d/postgresql restart

Para verificar que todo quedo bien instalado pondremos un archivo llamado prueba.php en la carperta /var/www/ con el siguiente contenido

<?
phpinfo();
?>

Abrimos el navegador de internet y navegamos la URL http://127.0.0.1 y deberiamos ver algo asi:

 

en particular para verificar que PHP tenga soporte para PostgreSQL en la zona media tenemos que encontrar un bloque de pgsql parecido al de la imagen que se ve a continuación

Fuente:

http://dcala.wordpress.com

Mayo 5th 2012

Solucionado (Problemas para instalar aircrack-ng) Ubuntu 12.04

Número de lecturas: 22117
{lang: 'es-419'}

Después de realizar la actualización de ubuntu 11.10 a la versión 12.04 sucede que ya no tenia instalado aircrack, al ejecutar este comando:

sudo apt-get install aircrack-ng

Me mostraba un error que decia: “Software obsoleto y que se podia reemplazar por iw”

Buscando la solución se me ocurrio ir a los repositorios para descargar y luego instalar aqui estan los enlaces:

Paquete para 32 bits:
https://launchpad.net/ubuntu/precise/i386/aircrack-ng/1:1.1-1.1build1

Paquete para 64 bits:
https://launchpad.net/ubuntu/precise/amd64/aircrack-ng/1:1.1-1.1build1

Se instalan con un doble click o desde la terminal.

Con esto se soluciona el problema.